Minimum requirements for Google Analytics Dashboard for WP

Last Updated on April 30, 2017 by Chris Christoff

In this documentation page you’ll find answers for frequently asked questions about Google Analytics Dashboard for WP.

If you have any errors displayed under Google Analytics -> Errors & Debug, you should start by checking these error codes first.

If you can’t find the right answer, go to WordPress.org support forums and drop a question there. Try to give as many details as possible about your issue.

Minimum requirements for Google Analytics Dashboard for WP

To run Google Analytics Dashboard for WP on a single install you need:

  • A Google Analytics account. To create a new Google Analytics account follow this tutorial.
  • WordPress version 3.5 or greater
  • PHP cURL or fopen() enabled with SSL support
  • HTTPS access to www.googleapis.com and gadwp.deconf.com
  • The same PHP minimum requirements as WordPress

To run Google Analytics Dashboard for WP on a multisite install you need:

  • A Google Analytics account. To create a new Google Analytics account follow this tutorial.
  • WordPress version 3.8 or greater
  • PHP cURL or fopen() enabled with SSL support
  • HTTPS access to www.googleapis.com and gadwp.deconf.com
  • The same PHP minimum requirements as WordPress

Please note that the SSL support for PHP cURL and / or fopen() is unrelated to your website’s protocol. Shortly, it doesn’t matter if your website uses HTTP or HTTPS, it’s unrelated to this requirement.